[#] Suma.iloczynów() - zapomninana, użyteczna funkcja

( Ostatnio zmieniony sob., 04/07/2009 - 13:26 )
 

Problem

Napisać formułę, ktora będzie działała tak jak SUMA.JEŻELI, ale będzie spełniała dwa warunki. Kolumna Kwota, powinna być sumowana jeżeli spełnione zostaną warunki w kolumnach Grupa i Kategoria.

Rozwiązanie – SUMA.ILOCZYNÓW()

=SUMA.ILOCZYNÓW( ( B4:B10 ) * ( C4:C10 = B16 ) * ( D4:D10 = C17 ) )

INNE ZASTOSOWANIE

Suma co trzeciej wartości kolumny

Przykład 1:
=SUMA.ILOCZYNÓW((A6:I6)*(MOD(KOLUMNA(A6:I6);3)=0))

Przykład 2:
=SUMA.ILOCZYNÓW((B6:J6)*(MOD(KOLUMNA(B6:J6)-1;3)=0))

4.8
Twoja ocena: Brak Średnio: 4.8 (5 głosów)